
 Using Registry Pro
Registry Pro (for Windows 95 only) lets you perform advanced editing of the value entries for key handles 
(the top level folders) and their subordinate child keys in the Windows 95 Registry database. With 
Registry Pro, you can troubleshoot and repair start-up files defined as entries in the Registry. You can 
import and export registry files, find entries containing specified text, or find orphans (entries for programs 
that have moved or no longer exist).
Tip Choose Key Info from the Help menu to get information on any selected key.

The procedures you can perform in Registry Pro are described in these help topics:

Finding a Registry Entry 
Finding Orphans 
Editing a Registry Entry 
Importing a Registry File 
Exporting a Registry File 
Refreshing the Registry Database 

Related Topics

Nuts & Bolts Contents 



Finding a Registry Entry

You can find Registry key entries that contains the text you specify.

To find a Registry entry:

1. Start Registry Pro by doing one of the following:

Click the Start button and choose the Program > Nuts & Bolts > Registry Pro command in 
Windows 95.

Open the Nuts & Bolts folder and double-click the Registry Pro icon from the Windows 95 
Explorer window.

The Registry Pro window appears.

2. Choose the Find command from the Search menu (or press Ctrl-F3).

The Find Results dialog box appears.

3. Enter the information you want to find in the Search text box.

4. Select where the information you're looking for can be located (as a key name, value name, or data).

5. Select whether to search the entire registry or a selected key.

6. Select whether to match whole words only and whether the search should be case sensitive (whether 
Registry Pro should distinguish between uppercase and lowercase letters).

7. Select whether to display the search results or whether to display the first occurrence.

When the process is complete, Registry Pro closes and returns you to the desktop.



Finding Orphans

An orphan is an entry for a program that has moved or no longer exists. Registry Pro lets you find the 
orphans that are in the Registry database so that you can edit them. 

Tip You can also let Registry Pro find and fix these orphans for you.

To find orphans:

1. Start Registry Pro by doing one of the following:

Click the Start button and choose the Program > Helix Software Nuts & Bolts > Registry Pro 
command in Windows 95.

Open the Nuts & Bolts folder and double-click the Registry Pro icon from the Windows 95 
Explorer window.

The Registry Pro window appears.

2. Choose the Find Orphans command from the Search menu.

Registry Pro displays a list of all the orphans it finds in the database in the Orphans tab. You can 
select an orphan key entry and Registry Pro selects it for you in the Registry database in the top two 
panels of the window.

You can double-click an orphan entry in the top right panel to change its value data. See Editing a 
Registry Entry.



Editing a Registry Entry

You can edit a Registry key entry in the list in the Registry Pro window.

To edit a Registry entry:

1. Start Registry Pro by doing one of the following:

Click the Start button and choose the Program > Nuts & Bolts > Registry Pro command in 
Windows 95.

Open the Nuts & Bolts folder and double-click the Registry Pro icon from the Windows 95 
Explorer window.

The Registry Pro window appears.

2. Double-click a database entry in the top right panel of the Registry Pro window.

The String Edit dialog box appears, displaying the value for the key you double-clicked.

3. Enter a new value and click OK.



Importing a Registry File

A Registry file contains a database of registry information including hardware, system, program, and 
network user settings about your PC. The Registry file in use on your PC is located in your Windows 
folder on the system hard drive.

You can import a a Registry file that has been created elsewhere, or one exported earlier, into Registry 
Pro so you can examine it or edit its contents. When you export a Registry file, you can save it with a 
unique filename in any location you like. This lets you create and use different Registry databases for 
particular purposes if you like.

To import a Registry file:

1. Start Registry Pro by doing one of the following:

Click the Start button and choose the Program > Nuts & Bolts > Registry Pro command in 
Windows 95.

Open the Nuts & Bolts folder and double-click the Registry Pro icon from the Windows 95 
Explorer window.

The Registry Pro window appears.

2. Choose the Import Registry File command from the File menu.

The Open dialog box appears.

3. Locate a Registry file (with a file type of .REG) and click Open.

Registry Pro opens the Registry file you selected in the Registry Pro window, displaying its key 
handles and child keys, along with key values of a key you select.



Exporting a Registry File

You can export the Registry file that is open in Registry Pro, saving it with a unique filename and a file 
type of .REG. You might want to do this to keep multiple Registry files for different purposes, or to share a 
Registry file with someone else.

To export a Registry file:

1. Start Registry Pro by doing one of the following:

Click the Start button and choose the Program > Nuts & Bolts > Registry Pro command in 
Windows 95.

Open the Nuts & Bolts folder and double-click the Registry Pro icon from the Windows 95 
Explorer window.

The Registry Pro window appears.

2. Choose the Export Registry File command from the File menu.

The Save As dialog box appears.

3. Enter a Registry filename (with a file type of .REG) and click Save.

Registry Pro exports the Registry file to the location you specified.



Refreshing the Registry Database

You can refresh the Registry database so that it displays the latest information stored in the active 
Registry file in your Windows folder on the system hard drive.

To refresh the Registry database:

1. Start Registry Pro by doing one of the following:

Click the Start button and choose the Program > Nuts & Bolts > Registry Pro command in 
Windows 95.

Open the Nuts & Bolts folder and double-click the Registry Pro icon from the Windows 95 
Explorer window.

The Registry Pro window appears.

2. Choose the Refresh command from the View menu.

Registry Pro updates the information in the Registry database.



Registry Pro Window

This window contains the following options:

Registry Database List
The Registry Database list contains a list of top-level key handles, child keys which are subordinate to the 
key handles, key names and key value data. You can double-click key handles and child keys to open 
them and view their contents, which appear in the panel at the right.

If you double-click a key's values in the panel at the right, the String Edit dialog box appears so you can 
edit that value.

Find Tab
If you use the Find command from the Search menu, the resulting find results list appears in the Find tab 
at the bottom of this window.

Orphans Tab
If you use the Find Orphans command from the Search menu, the resulting orphans list appears in the 
Orphans tab at the bottom of this window.



Find Tab

The Find tab appears at the bottom of the Registry Pro window after you perform a successful search. It 
contains a list of key entries that match the search criteria you specified when using the Find command 
from the Search menu. You can double-click an entry in this list and Registry Pro selects it for you in the 
Registry Database list in the top panels of the Registry Pro window.

Click the Find tab to bring it to the front.

You can resize the panel that contains the Find and Orphans tabs by dragging the horizontal bar above 
the tabs upward or downward. This lets you change the number of entries that are visible the Find list.



Orphans Tab

The Orphans tab appears at the bottom of the Registry Pro window after you find orphans in your 
Registry database. It contains a list of key entries that are considered orphans (their programs have either 
been moved or deleted). You can double-click an entry in this list and Registry Pro selects it for you in the 
Registry Database list in the top panels of the Registry Pro window.

Click the Orphans tab to bring it to the front.

You can resize the panel that contains the Find and Orphans tabs by dragging the horizontal bar above 
the tabs upward or downward. This lets you change the number of entries that are visible the Orphans 
list.



Find Results Dialog Box

This dialog box contains the following options:

Search String
Enter the text you want to find in the Search String text box.

Where
Select the check boxes where you want Registry Pro to look for matching text. You can select the Key 
Name, Value Name, and Data.

Search Items
Select whether you want Registry Pro to search the entire Registry database or only a selected key. If you 
select Selected Key, Registry Pro only searches the key handle or child key and its subordinate keys that 
were selected before you chose the Find command from the Search menu.

Match Whole Words Only
Select this check box if you want Registry Pro to only consider whole words as a match to the text you 
entered in the Search text box.

Case Sensitive
Select this check box if you want Registry Pro to require the text in the database to match the case 
(uppercase or lowercase) of the Search text you entered.

Display Find Results
Select this check box if you want Registry Pro to display the results of your search in the Find tab.

Display First Occurrence
Select this check box if you want Registry Pro to select the first occurrence in the Registry Database list 
that matches your search criteria.

Find
Specify your search criteria in the text box and check boxes. Then click Find to perform the search. If any 
items match your search criteria, Registry Pro displays them in the Find tab at the bottom of the Registry 
Pro window.

Cancel
Click Cancel to close the Find Results dialog box without performing a search.



String Edit Dialog Box

This dialog box contains the following options:

Value Name
The Value Name displays the value name for the key that you double-clicked.

Value Data
The Value Data text box displays the current value data for the key that you double-clicked. You can 
change this entry in the text box.

Save
Click Save to save your changes to the value data and return to the Registry Pro window.

Cancel
Click Cancel to close the String Edit dialog box without changing the value data.



Open Dialog Box

Registry Pro displays a standard Windows Open dialog box where you can select a Registry file that you 
want to import. You can select a drive and folder where the file is located and then select the file from the 
list. Or you can enter the path to the Registry file in the File Name text box. Once you've entered or 
selected the file to import, click the Open button.



Save As Dialog Box

Registry Pro displays a standard Windows Save As dialog box where you select a drive and folder where 
you want to store the Registry file you are exporting. You can also select whether to export all the keys in 
the Registry or only a specified branch of keys.

Once you've specified the location where the Registry file should be saved and a filename for it, click the 
Save button to export the current Registry file.



Address Space

The sum total of all possible memory addresses available at a given time. This is 4 GB (gigabytes) on a 
386 or later PC in protected mode.



Launch Pad

The Launch Pad is a window where you can place application and document icons so you can 
conveniently access them.



Benchmarks

A benchmark is a standardized task that tests various devices for measurements, such as speed.



BIOS

The BIOS (or Basic Input/Output System) contains buffers for sending information from an application to 
the hardware device, such as a printer, where the information should go.



Buffers

A buffer is a temporary storage location for information being sent or received.



Bytes

A byte is eight bits of information composed of zeros and ones, one of which may be a parity bit. Most 
character sets, such as ASCII, use one byte to represent each character (letter, number, or special 
symbol).



Cache

A cache is part of the computers memory used to temporarily store recently accessed information. A 
cache is designed on the premise that recently used information may be needed again soon. Keeping 
information available in cache reduces the time it takes for an application to obtain the information again.



Cluster

A cluster is a unit of storage allocation usually consisting of four or more 512-byte sectors.



Conventional Memory

Conventional memory is the first 640 K (kilobytes) of RAM (random access memory).



CPU (Central Processing Unit)

The brain of your computer. This is main computer chip that controls all activity that takes place on a 
computer.



Diagnostics

Diagnostics are tests run to detect faults in a computer system. Diagnostics tests are run to detect faults 
before they become serious problems so the faults can be corrected.



Directories

Directories are locations within a volume on a drive where you can store files or subdirectories. In 
Windows 95, directories are equivalent to folders that appear on the desktop in a drive window.



Discardable Memory

Discardable memory is memory used by an application that it has marked as discardable. Windows can 
reallocate the discardable memory to a different application if it needs to.



DLLs (Dynamic Link Libraries)

A DLL is an executable code module that can be loaded on demand and linked at run time. DLLs can be 
shared among multiple applications and independently updated, transparent to the applications. DLLs can 
also be unloaded when they are no longer needed.



DMA (Direct Memory Access)

DMA is a fast method of moving information from a storage device or LAN interface card directly to RAM 
which speeds processing time. DMA is direct memory access by a peripheral device that by-passes the 
CPU to save time.



Expanded Memory

DOS running on the Intel 80286, 80386, or 80486 family of computers can only address one megabyte of 
memory at one time. Expanded memory is the memory located between the base memory (either 512 K 
or 640 K) and one megabyte. Expanded memory is reserved by DOS for housekeeping tasks, such as 
managing information that appears on the screen.



Extended Memory

Memory above one megabyte in 80286 and higher PCs. Extended memory can be used for RAM disks, 
disk caches, or Windows, but it requires the CPU to run in a special mode (protected mode or virtual real 
mode).



FAT (File Allocation Table)

The FAT is a roadmap, or index, that points to the location where all the information in files is stored on a 
floppy disk or hard drive. The FAT is extremely important because the system uses it to store and retrieve 
files containing information.

When you save a file in Windows, it is stored in multiple pieces (in clusters made up of multiple sectors) 
on the disk. Windows also saves the roadmap, or index, that points to these clusters in two copies of the 
FAT (File Allocation Table). The FAT contains the directions to all the pieces of your files, so that 
applications can find them again later.



GDT (General Description Table)

The GDT is a table that is basic to the operation of protected mode. This table contains data structures 
(descriptors) that describe various regions of memory and how they may be accessed. Windows uses the 
GDT for system devices. See LDT.



Global Heap

The Global Heap is the general pool of memory available to Windows applications.



GPF (General Protection Fault)

An error condition caused by an application when it attempts to perform an operation not allowed by the 
operating system. Windows uses GPFs to determine and control the state of the currently executing 
application. GPFs that are unexpected by Windows cause a system error message to appear.



HMA (High Memory Area)

The HMA is the first 64 K of extended memory. If you use DOS 5.0, you can save memory by loading 
DOS into the HMA. Do this by adding the DOS=HIGH setting to your CONFIG.SYS file and restarting 
your PC.



Interrupt

A temporary suspension of a process caused by an event outside that process. More specifically, an 
interrupt is a signal or call to a specific routine. Interrupts allow peripheral devices, such as printers or 
modems, to send a call to the CPU requesting attention.



I/O (Input/Output) Device

An I/O device is any piece of computer hardware that can exchange information with the CPU. Examples 
of I/O devices include network cards, printers, speakers or other sound devices, or devices connected to 
the serial or parallel ports of your PC such as external modems.



Kernel

The Kernel is the part of a computer operating system that performs basic functions such as switching 
between tasks.



LDT (Local Descriptor Table)

The LDT is a secondary data structure table that contains additional information about various regions of 
memory and how they can be accessed. Windows uses the LDT for programs.



Linear Memory

Linear memory is the currently defined address space of the system that Windows uses to allocate 
memory to Windows applications.



Local Heap

The Local Heap is a region of memory allocated for local use by an application.



Locked Memory

Locked memory is memory used by an application that cannot be relocated or discarded by Windows.



Mapping

Mapping is the process of assigning physical memory (RAM) to a particular linear address range.



Mode Switch

A mode switch is a transition made by the CPU when changing from one mode of operation to another. 
For example, switching from real or protected mode, or a transition between different levels of protection. 
See Ring 0, 1, 2, 3.



Modules

A module is a device driver loaded by Windows.



Paging

The process of saving information stored in RAM to the swap file on the system hard drive so Windows 
can make the RAM available at a different linear address.



Parallel Port

The parallel port is a connector on the back of your PC and on some peripheral devices. With the 
appropriate driver software installed and a parallel cable connected to the parallel ports on your PC and a 
peripheral device, the two can communicate with each other. Parallel transmissions have no EIA 
standard, but most equipment follows a quasi-standard called the Centronics Parallel Standard.



PCI (Peripheral Component Interconnect) Bus

The PCI Bus is a local motherboard specification (that provides connector slots on the motherboard for 
installing peripheral cards). The PCI Bus, designed by Intel, offers a high performance, peripheral 
component level interface to the CPU bus.



Physical Memory

Physical memory is the RAM (Random Access Memory) installed in your PC. See Random Access 
Memory (RAM).



Protected Mode

A mode of operation of 80286 or later CPUs which allows access to more than 1 MB of memory.



RAM (Random Access Memory)

RAM (Random Access Memory) is also called physical memory. It is installed in your PC on SIMMs 
(Single Inline Memory Modules) or DIMMs (Dual Inline Memory Modules). RAM is volatile, extremely 
high-speed storage used by your computer for processing information.



Real Mode

A mode of 80286 or later CPUs, where the CPU operates substantially like an older 8086 CPU and can 
address directly only 1 MB of memory.



Resources

Resources are objects that Windows and its applications can use, such as the buttons on the screen that 
you can click.



Ring 0, 1, 2, 3

Different levels of protection in protected mode, where programs having varying degrees of freedom of 
operation. Ring 0 (zero) is least protected and has direct access to all hardware in the system.



Sector

A sector is a pie-shaped portion of a hard disk. A disk is divided into tracks and sectors. Tracks are 
complete circuits and are divided into sectors. Under DOS, a sector is 512 bytes.



Serial Port

A serial port is an input/output port (connector) that allows the transmission of information out at one bit at 
a time, as opposed to parallel which transmits eight bits, or one byte at a time.



Swap File

The swap file is created by Windows on the system hard disk. It uses the swap file to copy information 
stored in part of the linear address space so it can reallocate the RAM used at that location to another 
linear address space.



Swapping

Swapping is the process of saving to disk or restoring from disk the contents of RAM so that the RAM can 
be used elsewhere in linear memory.



System Resources

System resources are a series of data structures kept by Windows. System resources are managed by 
the Windows User and GDI programs and maintain information about objects that appear on your screen. 
For instance, for each button on your screen the User program has to know where it is supposed to be 
located, what program owns it, and which part of the program needs to be notified when you click the 
button. GDI must maintain information about pens used to draw lines on screen, fonts used to draw 
characters, and so on.

The information about the various objects managed by the User and GDI programs is kept in six 64K 
regions of memory known as resource heaps. These regions are actually 64K local heaps. These regions 
are 64K because 64K is the maximum size a 16-bit program can deal with efficiently. User and GDI are 
16-bit programs because Windows was originally designed to run on the Intel 8088 and 80286, 16-bit 
processors.

The User Resource Heaps are divided into:

The Window Heap, which contains information on windows and controls

The Menu Heap, which contains information on drop-down menus

The Menu String Heap, which contains the text messages that appear in the menus

The User Atom Heap, which contains mostly Window titles
The GDI Resource Heaps are:

The main GDI Resource Heap, which contains pens, brushes, fonts and various other information 
related to displaying Graphics

The GDI Atom Heap, which contains some font related information including font names.
The GDI and User Atom Heaps are usually discounted because the information in them is subsidiary to 
the other Local Resource Heaps. So, the other Heaps would always fill up before the Atom Heaps. The 
same is still true if Hurricane's Heap Expander (another Helix Software product) is loaded, although all the 
Heaps have been greatly expanded (now you understand the "Heap Expander" name too).



32BDA (32-Bit Disk Access)

32BDA is a process in Windows where the device driver that accesses the disk runs entirely as a 32-bit 
program at Ring 0 (zero).



32BFA (32-Bit File Access)

32BFA is a process in Windows where the DOS file operations are controlled by a program, or set of 
devices, that operate entirely as 32-bit programs at Ring 0 (zero).



Unlocked Memory

Unlocked memory is physical memory that Windows can copy to the swap file on disk, and whose linear 
address can be changed whenever Windows chooses.



UMB (Upper Memory Block)

The UMB is the area in memory between 640 K and 1 MB that have RAM mapped into them by memory 
managers, such as Helixs Netroom or MemMaker. See Expanded memory.



V86 Mode (Virtual 8086 Mode)

V86 mode is a mode of operation of 80386 or later CPUs where programs, originally designed to run in 
real mode, can run as sub-programs to a protected mode control program or operating system.



Video Memory

Video memory, called VRAM, is physical memory installed on your PCs video card that is used for 
displaying information on the screen.



Virtual Memory

Virtual memory is the amount of memory that exists either as physical memory (RAM) or on the hard drive 
(in the swap file). When a part of memory that is located in the swap file is accessed by an application, 
Windows reads the information into RAM.



VMs (Virtual Machines)

Virtual machines (also called Virtual DOS machines or VDMs) are created in Windows 95 when you open 
a MS-DOS Prompt window. The VDM is a software emulation of a separate computer, offering all the 
services that the DOS application expects of a PC.



VxDs (Virtual Device Drivers)

VxDs are used in Windows 95 to communicate with all physical hardware in the system. This prevents 
any application from having direct access to a piece of hardware. Instead, it communicates only through 
the VxD for that hardware.



Windows 95 Registry

The Windows 95 Registry file contains user, application, and computer-specific configuration information 
in a central location that was kept in various .INI files in Windows 3.1. The Registry contains settings that 
determine how your computer runs.



Hidden Files

A hidden file is any file that does not show up in a regular directory listing. Typically, hidden files have one 
of the following file extensions:

DLL-(Dynamic Link Library)

SYS-System file

VXD-Virtual Device Driver

386-Virtual Device Driver

DRV-Device Driver
In Windows, a programmer can set any file with the hidden file attribute.

Tip In Windows Explorer or My Computer, you can select to show or hide hidden files. To do this, 
choose the Options command from the View menu, click the View tab, select the Show or the 
Hide radio button, and click OK.



System Files

A system file is a file used exclusively by the operating system, or Windows.




